Opened 10 years ago

Closed 10 years ago

#833 closed bug (fixed (in master))

(r1362) Random Artifact Names on Standard Artifacts

Reported by: anonymous Owned by: magnate
Milestone: 3.1.1 beta Keywords: Randarts
Cc:

Description

When character save file is reused to maintain monster memory with adult_randards disabled artifact names remain randomized after playing a prior character with adult_randarts enabled. However the artifacts are properly generated from the standard set.

Examples:

[Hithlomir]
f) The Soft Leather Armour of Elorim [4,+20] (+4)

+4 stealth.
Provides resistance to acid, lightning, fire, cold, dark.
Cannot be harmed by acid, electricity, fire, cold.


[Mudwine]
k) The Lochaber Axe of Gardairme (3d8) (+12,+17)

Slays animals, evil creatures, demons.
Provides resistance to acid, lightning, fire, cold.
Cannot be harmed by acid, electricity, fire, cold.

Attachments (2)

Test (53.1 KB) - added by anonymous 10 years ago.
Test.txt (5.2 KB) - added by anonymous 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by anonymous

Changed 10 years ago by anonymous

comment:1 Changed 10 years ago by anonymous

Workaround: The problem seems to correct itself if a new or other save file is opened which has never enabled adult_randarts. After restarting the bad save file, standard artifact names appear again on correct items.

comment:2 Changed 10 years ago by magnate

  • Owner set to magnate
  • Status changed from new to assigned

Ok, will see if I can work out why this is happening. The workaround suggests that something remains in local memory between games, which is odd. (If the save file itself was "bad", the workaround wouldn't work.)

comment:3 Changed 10 years ago by magnate

One thought: what platorms has this behaviour been observed on? On Linux I get a similar but different problem: if I've been using randarts with the previous character, and I go into birth options and unset Use Randarts during the generation of my new character (i.e. before rolling stats), the option change doesn't take effect! The new character is generated with a set of randarts, and when I look at its birth options, Use Randarts is still set. So I can't reproduce your exact problem, but a similar one.

comment:4 Changed 10 years ago by anonymous

I'm seeing this on Mac OSX PPC

comment:5 Changed 10 years ago by takkaria

  • Milestone changed from Triage to 3.1.1 beta

comment:7 Changed 10 years ago by magnate

Ok, I finally worked out why this is happening. The names aren't being randomised at all. What's happening is that the dead character's randart names are being loaded before the new character is generated. Then because randarts has been turned off, the randart code isn't called and the names are left untouched. That's how we end up with standard artifacts with random names. Just working out how to fix it.

comment:8 Changed 10 years ago by magnate

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [9a76672] (SVN r1377) (my analysis above was wrong, but gave me enough of a push to get there).

Note: See TracTickets for help on using tickets.