Opened 9 years ago

Closed 7 years ago

#838 closed bug (fixed (in master))

isolated initial room

Reported by: anonymous Owned by:
Milestone: 3.3.0 Keywords: dungeon
Cc:

Description

This is an old bug, and presumably well known, but just in case someone wants a savefile example I'm reporting it again.

Attachments (1)

1000.Eddie.noexit (48.0 KB) - added by eddiegrove@… 9 years ago.
savefile with initial isolated room

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by eddiegrove@…

savefile with initial isolated room

comment:1 Changed 9 years ago by magnate

  • Keywords dungeon added
  • Milestone changed from Triage to 3.1.2 beta

comment:2 Changed 8 years ago by magnate

  • Milestone changed from 3.2.0 to 3.3.0

Punting to 3.3: non-urgent bug or change.

comment:3 Changed 8 years ago by magnate

  • Status changed from new to confirmed

Assume this can still happen, though of course it is hard to reproduce at will.

comment:4 Changed 8 years ago by fizzix

I have a code that can reproduce this bug. Most disconnected rooms are caused by GVs blocking off access from some section of the dungeon. However, there is a small percentage of dungeons that just have rooms isolated from the rest of the dungeon, either individually or in groups.

Prevalence of isolated rooms on dlevel 1 is calculated to occur between 1 and 4 times in 10000 generations.

comment:5 Changed 7 years ago by magnate

  • Resolution set to fixed
  • Status changed from confirmed to closed

d_m assures me that this can no longer happen.

Note: See TracTickets for help on using tickets.