Opened 10 years ago

Closed 5 years ago

#888 closed bug (fixed (in master))

CCW and CMW (almost) replicated

Reported by: fph Owned by:
Milestone: 3.5.0 Keywords: magic
Cc:

Description (last modified by takkaria)

The CCW and CMortalW priest/paladin spells are replicated in ?PB3 and "Purifications and Healings". The former spell is the same in both copies, but the two copies of CMW differ (the one in PaH costs more mana and has a higher fail rate, for a paladin at least).
Is that intended?

Change History (9)

comment:1 Changed 10 years ago by magnate

  • Keywords magic added; spells healing removed
  • Milestone changed from Triage to 3.1.2 beta

comment:2 Changed 9 years ago by magnate

  • Status changed from new to confirmed

I think this is intended, in that PaH (together with other dungeon books) is supposed to replace PB3 in the late game. Leaving to Takkaria to close as wontfix if they agree.

Last edited 6 years ago by takkaria (previous) (diff)

comment:3 Changed 8 years ago by magnate

  • Resolution set to wontfix
  • Status changed from confirmed to closed

Closing as agreed with takkaria on IRC.

comment:4 Changed 6 years ago by damerell

  • Milestone changed from 3.2.0 to 3.5.0
  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Type changed from bug to change

I'm reopening this because I think the original reporter's issue was missed. That PaH duplicates some spells from earlier priest books is expected - just as Wrath of God duplicates the Dispels. The issue, however, is that for a Paladin, the copy of CSW in PaH is worst in every respect to that in PB2 - higher level, higher mana, worse failure chance. The copy of CMW in PaH can be cast at level 23 not 25, but also carries higher mana and a worse failure chance.

This makes finding PaH a bit of a non-event for a Paladin - at level 45 one can stop stocking Mushrooms of Vigor, hooray - since the other two spells in the book are (illegible). Surely the intention is that the dungeon book provides slightly better versions of the spells (as it does for Priests), not slightly worse ones?

comment:5 Changed 6 years ago by takkaria

  • Description modified (diff)
  • Type changed from change to bug

Point taken.

comment:6 Changed 6 years ago by takkaria

  • Resolution set to fixed (in master)
  • Status changed from reopened to closed

Fixed in 1fa0557.

comment:7 Changed 6 years ago by PowerWyrm

Still not completely fixed I think. The best would be to apply the same method as for the Dispel prayers: the second version is 20% lower level and costs half the mana. Something like this:

(based on)
Cure Serious Wounds (PB2): Priest (5/4) Paladin (11/9)
Cure Mortal Wounds (PB3): Priest (13/11) Paladin (25/20)

(change to)
Cure Serious Wounds (PB7): Priest (4/2) Paladin (9/5)
Cure Mortal Wounds (PB7): Priest (10/6) Paladin (20/10)

comment:8 Changed 6 years ago by takkaria

  • Resolution fixed (in master) deleted
  • Status changed from closed to reopened

Reopening to take a look.

comment:9 Changed 5 years ago by takkaria

  • Resolution set to fixed (in master)
  • Status changed from reopened to closed

OK, thanks, I've followed your suggestion for paladins in 974dc57

Note: See TracTickets for help on using tickets.