Opened 10 years ago

Closed 8 years ago

#891 closed change (fixed (in master))

Display player-turns in dumps

Reported by: magnate Owned by: magnate
Milestone: 3.2.0 Keywords: dump
Cc:

Change History (12)

comment:1 Changed 10 years ago by magnate

  • Keywords dump added

comment:2 Changed 10 years ago by magnate

  • Keywords backport added

comment:3 Changed 10 years ago by magnate

  • Status changed from new to assigned

comment:4 Changed 10 years ago by magnate

[dc9b49f] (SVN r1661)

comment:5 Changed 10 years ago by magnate

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 9 years ago by magnate

  • Keywords backport removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

Competition 88 has established two fairly major weaknesses in the counting of player turns:

  1. Extra shots are penalised: one player turn is added per shot
  1. Speed is penalised, e.g. more player turns used while resting or waiting for recharges (#957 also struck this problem)

Since the whole reason for counting player turns was to eliminate the advantage that early speed finds give when counting game turns, these issues are not really tolerable. Player turns should be replaced with a count of total energy used, which suffers from none of these anomalies. (If we define a "standard turn" as 100 energy, we can express things like effect durations and recharge times in standard turns.)

comment:7 Changed 9 years ago by magnate

Eddie points out that since recharges are defined in game turns, extra speed is penalised when measuring anything else, including total energy.

Recharge times need to be redefined in player turns, or better still in total energy required. One to discuss with Takkaria.

comment:8 Changed 9 years ago by magnate

  • Milestone changed from 3.1.2 beta to 3.1.3

comment:9 Changed 9 years ago by magnate

This is now mostly fixed in http://github.com/magnate/angband/tree/fracblows - extra shots, fractional blows and speed are now all irrelevant because we measure total energy used (and divide by 100 for "standard turns"). The only outstanding problem is recharge times.

comment:10 Changed 9 years ago by magnate

  • Status changed from reopened to confirmed

I think I have come round to the idea that recharge times should remain completely independent of player speed. They're part of process_world() and should stay that way. We just have to cope with the fact that the faster you get, the more actions you get to take while things are recharging: the absolute recharge time doesn't change, it just longer relative to your speed. Confirming this as is: will close when committed to master.

comment:11 Changed 9 years ago by magnate

  • Milestone changed from 3.2.0 to 3.3.0

Punting to 3.3: non-urgent bug or change.

comment:12 Changed 8 years ago by magnate

  • Milestone changed from 3.3.0 to 3.2.0
  • Resolution set to fixed
  • Status changed from confirmed to closed

Ooops - this was actually committed in 3.2

Note: See TracTickets for help on using tickets.