Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#893 closed bug (fixed (in master))

Pickup fails when hitpoints low

Reported by: noz Owned by: d_m
Milestone: 3.1.1 beta Keywords:
Cc:

Description

With hitpoint warning on (40%), pickup_always=yes, pickup_inven=yes, pickup_detail=yes

When hitpoints fall below the low hitpoint warning, walking over an item no longer picks it up, instead resulting in the "You see a..." message.

Change History (6)

comment:1 Changed 10 years ago by noz

Looks like this is deliberate: (from cmd1.c)

static bool auto_pickup_okay(const object_type *o_ptr)
{
        /* Bad wounds prelude autopickup */
        if (p_ptr->chp < (p_ptr->mhp * op_ptr->hitpoint_warn / 10)) return FALSE;
        ...

but it should either give a different error message, or be documented somewhere...

comment:2 Changed 10 years ago by magnate

Heh. That's the first time I've seen prelude used as a verb.

comment:3 Changed 10 years ago by takkaria

  • Milestone changed from Triage to 3.1.1 beta
  • Status changed from new to confirmed

comment:4 Changed 10 years ago by d_m

  • Owner set to d_m
  • Status changed from confirmed to assigned

I'll try to print some sort of error message about this.

comment:5 Changed 10 years ago by d_m

  • Resolution set to fixed
  • Status changed from assigned to closed

I have removed this feature (suppressing auto pickup when HP are low).

The problem with an error message is it needs to say the following:

"You didn't auto pickup this item because your HP are too low, but you can always pick it up manually"

But it needs to say it "in-character". Otherwise, the "feature" seems like a bug to people who play with auto pickup.

comment:6 Changed 10 years ago by anonymous

How About Something along the lines of "you are to injured to pickup blah" ?

Note: See TracTickets for help on using tickets.