Opened 10 years ago

Closed 6 years ago

#905 closed bug (fixed (in master))

Some Monster Tiles Mapped to Wrong Graphic

Reported by: wolf.trickster@… Owned by: takkaria
Milestone: 3.5.0 Keywords: graphics
Cc:

Description (last modified by fizzix)

I noticed when playing 3.1.0 a while back that a few of the monster graphics appeared to be mapped to the wrong image (in Adam Bolt tileset). Some of these were duplicate monster pics, which may or may not have been an error. Notable was the air elemental unique, who looked like a fruit fly, but there were others. But I know this particular one was the wrong image because Adam used the same one for Ariel in Z.

Trickster

Change History (10)

comment:1 Changed 10 years ago by magnate

Possibly a duplicate of #820 (e.g. an off-by-one error).

comment:2 Changed 10 years ago by wolf.trickster@…

I thought they might be different; 820 affects nearly all the element tiles, while this one only affects a couple or a few monsters. But yeah, it could be from the same thing.

Trickster

comment:3 Changed 10 years ago by magnate

  • Milestone changed from Triage to 3.1.2 beta

comment:4 Changed 9 years ago by magnate

  • Milestone changed from 3.2.0 to 3.3.0

Punting to 3.3: non-urgent bug or change.

comment:5 Changed 8 years ago by magnate

  • Owner set to takkaria
  • Status changed from new to assigned

Assigning to takkaria per IRC.

comment:6 Changed 8 years ago by takkaria

Hey, if the original reporter gets an email with this in, please could you confirm this is still the case?

comment:7 Changed 8 years ago by magnate

  • Milestone changed from 3.3.0 to 3.4.0

Postponing to 3.4 per IRC

comment:8 Changed 7 years ago by fizzix

  • Description modified (diff)
  • Milestone changed from 3.4.0 to 3.5.0

Punting

comment:9 Changed 6 years ago by PowerWyrm

Feel free to look at the PWMAngband mappings for tiles in the graf-xxx.prf files. Angband monsters are numbered from 1 to 616. I've remapped a few tiles which were not correct.

For example, the problem described above still occurs: Ariel is mapped as 0x9F:0x91 in Angband (graf-new.prf), and 0x9F:0x90 in PWMAngband.

comment:10 Changed 6 years ago by takkaria

  • Resolution set to fixed (in master)
  • Status changed from assigned to closed

Thanks PowerWyrm?, I've nicked them all from PWM now. Fixed in 505d86d

Note: See TracTickets for help on using tickets.