Opened 10 years ago

Closed 10 years ago

#913 closed bug (invalid)

Character dumps have some stats on a new line when they shouldn't be

Reported by: schlittk@… Owned by:
Milestone: Triage Keywords:
Cc:

Description

there is a newline before the last entry in each row and it messes up the alignment. i'm very unfamiliar with the code but I took a peek and it seems to be something to do with where the character sheet is pulled to the screen, then the screen is dumped to the file

Attachments (2)

filedump.txt (5.1 KB) - added by schlittk@… 10 years ago.
what Angband 3.1.0b actually dumps
properfiledump.txt (5.1 KB) - added by schlittk@… 10 years ago.
what Angband 3.1.0b should dump

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by schlittk@…

what Angband 3.1.0b actually dumps

Changed 10 years ago by schlittk@…

what Angband 3.1.0b should dump

comment:1 Changed 10 years ago by anonymous

OK my bad, the contents of filedump.txt are not exactly what the game dumps because i actually had partially fixed it before i uploaded it and forgot that i had done that, but i think it's still clear from looking at the two files what the issue is

comment:2 Changed 10 years ago by takkaria

  • Summary changed from formatting issue with character dumps to Character dumps have some stats on a new line when they shouldn't be

I can't reproduce this. What platform are you using?

comment:3 Changed 10 years ago by schlittk@…

I'm running Windows Vista (and so obviously the windows version of Angband), and I read the dump files in Wordpad, if that matters.

Sorry for not including that information at the start.

Cheers.

comment:4 follow-up: Changed 10 years ago by takkaria

Hmm. Try opening in Notepad? :) I think this might be a WordPad? thing rather than an Angband thing, since Angband definitely doesn't dump a newline there.

comment:5 in reply to: ↑ 4 Changed 10 years ago by schlittk@…

notepad is worse. it doesn't recognize the line wraps at all but instead imposes its own 'style' which is horrible

however i opened a character dump with internet explorer and it looks fine....
so i think your right that it is not an angband issue

this is strange as i have never had issues with wordpad and c-text-file

anyways sorry to waste your time

cheers

comment:6 Changed 10 years ago by schlittk@…

i am embarassed to say that it is indeed a wordpad issue, sorry for the false alarm, cheers

comment:7 Changed 10 years ago by takkaria

  • Resolution set to invalid
  • Status changed from new to closed

no worries :)

Note: See TracTickets for help on using tickets.