Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#928 closed bug (invalid)

I can't attack while afraid, but mobs won't attack either.

Reported by: sergio.arizmendi@… Owned by:
Milestone: 3.1.2 beta Keywords: combat
Cc:

Description

I have been feared by a paladin (or some other mob, it's happened twice since I installed 3.1.1.1577. I can keep "pushing" the mob and it won't do anything since I'm too afraid to attack, but I can do this for 30 turns and the mob right next to me (the one that feared me) won't do anything either.

I attach savefile. Just keep pushing to the right and you'll see what I mean.

Attachments (1)

Lorina.bug (51.8 KB) - added by sergio.arizmendi@… 10 years ago.
Savefile reproducing the problem

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by sergio.arizmendi@…

Savefile reproducing the problem

comment:1 Changed 10 years ago by magnate

  • Keywords combat added; fear mobs attack removed
  • Milestone changed from Triage to 3.1.2 beta

Interesting. No idea why this is happening - it shouldn't have anything to do with [100cc75] (SVN r1540), but you never know.

comment:2 follow-up: Changed 10 years ago by rhinocesaurus

Somehow I can't seem to open the savefile (in 1157 on linux or windows), but if I understand the situation correctly, this is just the intended behaviour; trying to attack while afraid no longer takes a turn, so really no time is going by. If you stand still then the paladins should attack.

Is the new behaviour too confusing?

comment:3 in reply to: ↑ 2 Changed 10 years ago by magnate

Replying to rhinocesaurus:

Somehow I can't seem to open the savefile (in 1157 on linux or windows), but if I understand the situation correctly, this is just the intended behaviour; trying to attack while afraid no longer takes a turn, so really no time is going by. If you stand still then the paladins should attack.

Is the new behaviour too confusing?

Doh. Of course - well done. I think it's fine - it'll take people a while to get used to the fact that no turns are actually passing, but it's a sensible solution.

Unless of course turns *are* actually passing (i.e. other monsters moving, just not attacking the player). We'll need to check the savefile to confirm.

comment:4 follow-up: Changed 10 years ago by magnate

  • Resolution set to invalid
  • Status changed from new to closed

I have downloaded the savefile and tested that there is nothing wrong here. If you keep trying to attack the novice paladin, nothing will happen because no turns are passing. As soon as you do anything other than attempt a melee attack, the novice paladin attacks normally. Closing as invalid.

(P.S. rhinocesaurus - did you d/l from the "Original format" link on the attachment page?)

comment:5 in reply to: ↑ 4 Changed 10 years ago by rhinocesaurus

Replying to magnate:

(P.S. rhinocesaurus - did you d/l from the "Original format" link on the attachment page?)

Ah, that does the trick. Thank you :)

Note: See TracTickets for help on using tickets.