Opened 10 years ago

Closed 10 years ago

#940 closed bug (fixed (in master))

Investigate reports of macros/keymaps not restoring properly

Reported by: takkaria Owned by:
Milestone: 3.1.2 beta Keywords: keymap macro
Cc:

Change History (2)

comment:1 Changed 10 years ago by Nick

I think I've found the answer to this one in FA (after pinching code from V). In prefs.c, when parsing things of the form C:<num>:<str>, at one point the array index i is cast to a long (which seems reasonable, since that's what it is). The problem is that it's cast from a char, and if that char is a trigger like \x9C, it will try write the keymap to a negative entry of keymap_act. The solution is to cast to byte (and probably define i as byte to avoid warnings, although I don't think that affects the functionality).

comment:2 Changed 10 years ago by nckmccnnll

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.