Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#947 closed bug (worksforme)

Angband crashes on exit if an edit file contains a syntax error

Reported by: marcock@… Owned by:
Milestone: Keywords: cleanup
Cc:

Description

When an edit file contains a syntax error, Angband displays the error messages and then crashes, just before exiting normally.

Change History (4)

comment:1 Changed 10 years ago by magnate

  • Keywords cleanup added

comment:2 Changed 10 years ago by magnate

I can't reproduce this. I get:

Error at line 1 of 'object.txt'.-more-

Record -1 contains a 'missing colon' error. Parsing 'error'.-more-

... then a clean exit to:

src/angband: Error in 'object.txt' file.

Can you be more specific about the syntax that caused this behaviour?

comment:3 Changed 10 years ago by takkaria

  • Resolution set to worksforme
  • Status changed from new to closed

comment:4 Changed 9 years ago by magnate

  • Milestone Triage deleted
Note: See TracTickets for help on using tickets.