Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#949 closed bug (fixed (in master))

ACS_BULLET doesn't work on the linux console

Reported by: d_m Owned by:
Milestone: 3.1.2 beta Keywords: gcu
Cc:

Description

In addition to using ACS_CBOARD for walls, the curses graphics also use ACS_BULLET instead of "." for floor tiles. The advantage seems to be that terminals that provide the bullet center it more than the period.

The disadvantage is that under the Linux Console the bullet is a big ugly square (only slightly smaller than the wall).

First reported by Magnate on oook, but I've confirmed it.

Change History (7)

comment:1 Changed 10 years ago by d_m

  • Status changed from new to confirmed

comment:2 Changed 10 years ago by takkaria

My inclination here would be just not to change the graphic for floors.

comment:3 Changed 10 years ago by magnate

Hmmm. Where ACS_BULLET is a properly centred dot, I do think it is helpful. Since it works in almost all gcu invocations except a TERM=linux console, I think it is worth keeping. For the linux console one has three choices:

  1. Play without ACS graphics - i.e. #s for walls and periods for floors.
  1. Play with ACS graphics and manually edit your features to replace the ugly bullet with a period.
  1. Sort out your terminfo so that you can invoke angband using TERM=somethingelse and get a proper ACS_BULLET. I'm not sure if this one is possible, but it seems like it might be.

comment:4 follow-up: Changed 10 years ago by d_m

On a scale of 1-10, how bad is a hack specifically aimed at TERM=linux?

comment:5 in reply to: ↑ 4 Changed 10 years ago by magnate

  • Keywords gcu added

Replying to d_m:

On a scale of 1-10, how bad is a hack specifically aimed at TERM=linux?

Personally I'd love to see this if takkaria agrees. It seems a shame to ban such a hack when there are so many others!

comment:6 Changed 10 years ago by d_m

  • Resolution set to fixed
  • Status changed from confirmed to closed

As per takkaria's directive, period is now the default floor for the GCU font. Users who want bullets can override this from the knowledge/features menu.

comment:7 Changed 9 years ago by magnate

  • Milestone changed from Triage to 3.1.2 beta
Note: See TracTickets for help on using tickets.