Opened 9 years ago

Closed 7 years ago

#952 closed bug (wontfix)

No solid walls under -mgtk

Reported by: magnate Owned by:
Milestone: Triage Keywords: gtk
Cc:

Description

The gtk port does not appear to support the solid wall character, or the centred dot. When browsing the available characters (knowledge menu, features, visuals), the 0x02 character appears as a unicode-like square containing 0002.

Not knowing anything about gtk, I cannot diagnose why this is happening. But it doesn't happen with -mx11 or -msdl or -mgcu - all those show solid walls perfectly happily. (But see also #949 for centred dots with -mgcu when TERM=linux.)

This lack of support goes all the way back to 3.0.9b at least. It may relate to some change in gtk rather than any change in the angband code. We need a gtk expert to shed further light on this.

Change History (5)

comment:1 Changed 9 years ago by noz

Happens to me too.

However, if you change View | Graphics to "Old" tiles, then back to "None", the graphics go back to the familiar dot and hash.

comment:2 Changed 8 years ago by magnate

  • Milestone changed from 3.2.0 to 3.3.0

Punting to 3.3: non-urgent bug or change.

comment:3 Changed 8 years ago by magnate

  • Status changed from new to confirmed

comment:4 Changed 8 years ago by takkaria

It's because GTK isn't using the same fonts as other ports-- it's using system-wide fonts that have none of those characters in there. I think this is wontfix, since it's not really a bug.

comment:5 Changed 7 years ago by magnate

  • Milestone changed from 3.3.0 to Triage
  • Resolution set to wontfix
  • Status changed from confirmed to closed

It's also a wontfix because gtk is going away soon ...

Note: See TracTickets for help on using tickets.