Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#956 closed bug (fixed (in master))

printf formatting issues in dumps

Reported by: fph Owned by: d_m
Milestone: 3.1.2 beta Keywords: dump
Cc:

Description

I read in this (build 1642) dump http://angband.oook.cz/ladder-show.php?id=9297:

(in a "player note" added with the command ":" )
325767 4150' 40 !WIS from marilith, 0 0.000000ail again

It seems like some printf-like function failed on a note containing "%f".

Change History (5)

comment:1 Changed 10 years ago by d_m

  • Status changed from new to confirmed

I can confirm this bug. The easy way to replicate it is to take a note (:) and type "0%fail"

The bug does not seem to be in history.c but rather in the routines that write the dump. I imagine that the problem is that there is something like 'printf(msg)' when in fact to be safe it should be 'printf("%s", msg)'

I will investigate further.

comment:2 Changed 10 years ago by d_m

  • Owner set to d_m
  • Status changed from confirmed to assigned

comment:3 Changed 10 years ago by d_m

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in [02fe78d] (SVN r1650)

comment:4 Changed 9 years ago by John59

Joined-up educational planning across elements of the professional training programme The Diploma, PCC, traineeship and assessment of training exist separately. ,

comment:5 Changed 9 years ago by magnate

  • Keywords dump added
  • Milestone changed from Triage to 3.1.2 beta
Note: See TracTickets for help on using tickets.