Opened 10 years ago

Closed 8 years ago

#958 closed change (fixed (in v4))

re-add broken/worn weapon/armor types

Reported by: d_m Owned by: magnate
Milestone: v4 Keywords: items,affixes
Cc:

Description

There seems to be a desire to have back some of the old classics (broken sword, filthy rag, rusted chainmail, etc). As long as they are still useful (provide 1d1 damage or at least 1 AC) and can potentially be egos it seems fine, so I propose adding them back.

This would include putting Narsil back in. I would also propose "broken staff of Saruman" (with a potential activation) as well as some other damaged weapons/armor artifacts. A good standard to go on might be that every weapon or armor type should have at least one artifact.

Change History (9)

comment:1 Changed 10 years ago by magnate

  • Keywords items added; idea removed

I have some issues with doing this without any conjoint changes to item generation. These items were removed because they are almost always junk. I accept the argument about the loss of flavour, but we shouldn't simply revert the change. We should look at ways of ensuring that (e.g.) they are only generated on the first (say) 20 dungeon levels - or something.

I think this needs more discussion. I'm happy to see Narsil return, if we can avoid broken swords turning up too often. Note that you'll need a new base item type for Saruman's broken staff, which means new tval/sval etc.

comment:2 Changed 10 years ago by magnate

The other issue here was raised by Timo on rgra a while back: there are currently way more weapon type (for one equipment slot) than armour item types (for several slots). Ultimately this needs an overhaul of item generation to fix (#192, #720, #786), but in the meantime try to add more armour types than weapon types ...

comment:3 Changed 10 years ago by magnate

P.S. #526 is waiting on this, so feel free not to leave it until 3.2 ...

comment:4 Changed 10 years ago by takkaria

I'm pretty happy with the balance of weapons to armour at the moment, I spent a lot of time on this for 3.1.0. The issue is taht non-combat gear needs to be found more often, which I will get done for 3.1.2 but am yet to file a bug for...

comment:5 Changed 10 years ago by KZK

Their is a reason for the disparity between types for each, namely that their are actually that many more weapon designs than their are armor designs. Functionally their just aren't that many different ways to cover the head or the hands in useful way. Zangband has a whole bunch more weapons/armor types, and I think most of them would be welcome in the vanila branch. I don't really think their are too many people clamoring for reduced choice in weapons type, in fact I think it's the opposite.

Their are some armors you can add that are significantly different from existing ones. Frex: Vambraces. It's what Xena & Hercules wore in those shows. It's better than a glove, less than a guantlet, and doesn't cover the hands only the forearms (ideal for mages/casting). Make it a moderately rare item, deeper in the dungeon, and your all set.

comment:6 Changed 8 years ago by magnate

  • Keywords items,affixes added; items removed
  • Owner set to magnate

This ticket is addressed in (or enabled by) https://github.com/angband/angband/pull/94

comment:7 Changed 8 years ago by magnate

  • Milestone changed from 4.0 to 3.4.0
  • Status changed from new to pending

comment:8 Changed 8 years ago by magnate

  • Milestone changed from 3.4.0 to 4.0

Initial assignment to v4 per http://trac.rephial.org/roadmap

comment:9 Changed 8 years ago by magnate

  • Resolution set to fixed (in v4)
  • Status changed from pending to closed

Fixed in the affixes merge [r48ccc16f]

Note: See TracTickets for help on using tickets.