Opened 9 years ago

Closed 7 years ago

#959 closed task (wontfix)

Make --enable-gtk require Pango

Reported by: d_m Owned by:
Milestone: Triage Keywords: gtk pango
Cc:

Description

Aerdan points out on IRC that recent versions of GTK/GDK require Pango. But Angband still has #ifdef USE_PANGO stuff. sorear proposes that we require Pango for GTK, and then remove all that stuff and I agree.

Attachments (1)

959.patch (1.4 KB) - added by widget-angband@… 9 years ago.
Remove Pango #ifdefs

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by takkaria

  • Milestone changed from Triage to 3.1.2 beta
  • Status changed from new to confirmed

Go for it.

Changed 9 years ago by widget-angband@…

Remove Pango #ifdefs

comment:2 Changed 8 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

comment:3 Changed 8 years ago by magnate

  • Type changed from change to task

comment:4 Changed 7 years ago by magnate

  • Milestone changed from 4.0 to 3.5.0

These are all underlying or uncontroversial issues, unconnected with the experimental nature of v4 - therefore re-setting to V milestone.

comment:5 Changed 7 years ago by magnate

  • Milestone changed from 3.5.0 to Triage
  • Resolution set to wontfix
  • Status changed from confirmed to closed

GTK has now been removed so this is no longer an issue.

Note: See TracTickets for help on using tickets.