Opened 9 years ago

Closed 8 years ago

#973 closed bug (wontfix)

Wildcard (*) in stores accepts anykey

Reported by: KZK Owned by:
Milestone: 3.2.0 Keywords: stores
Cc:

Description

Does not affect using the Wildcard(*) to target creatures.

When in a store, and it prompts you for quantity or (*) if you press any key, say f, it acts the same as if you pressed *. This is a problem, because of how the store was changed from previous versions and some other variants such as Zangband, where you would normally press p (purchase), then press the letter corresponding to item purchased (selling items still works this way, an inconsistency), which in this case causes you to purchase all of whatever is selected accidentally. It is very easy to accidentally buy 37 Begining magic books, particularly if you were heavily playing a Variant with the old store code.

Change History (11)

comment:1 Changed 9 years ago by KZK

I also think that no macros or keymaps should work in stores, with the sole exception of an alternate wildcard (*) keymap, because not all keyboards have an easily accesible * key.

See #871 for other problems with macros.

comment:2 Changed 9 years ago by magnate

  • Keywords stores added
  • Milestone changed from Triage to 3.1.2 beta
  • Status changed from new to confirmed

comment:3 Changed 9 years ago by d_m

  • Resolution set to fixed
  • Status changed from confirmed to closed

As of [027f74f] (SVN r1692) only the star key (*) buys all.

comment:4 Changed 9 years ago by takkaria

I actually liked (and used) that feature, since it works in other variants too...

comment:5 Changed 9 years ago by anonymous

Huh. This is certainly an unpopular change. I guess I should revert it? It does seem unfriendly to beginners... although I suppose it does confirm the selection with a y/n prompt.

comment:6 Changed 9 years ago by d_m

P.S. That was d_m

comment:7 Changed 9 years ago by KZK

Things should work correctly if at all. What is the point of having the Wildcard at all if it has no effect? As I explained in my initial post, this is important because other Variants like Zangband do not use the new (inferior) shop code. It's also inconsistent with selling.

comment:8 Changed 9 years ago by magnate

  • Resolution fixed deleted
  • Status changed from closed to reopened

Unfixed in [666469a] (SVN r1709). See http://angband.oook.cz/forum/showthread.php?p=25686 for ongoing debate. Needs closing as wontfix or some other compromise, such as Marble Dice's suggestion that quantity defaults to a whole stack in every case except buying from stores (when the default is 1).

comment:9 Changed 9 years ago by KZK

I already explained how to 'fix' the problem all the whiners seem to have. Set the Wildcard (*) keymap to something else, like h. And for all those so called 'veterans' who are used to using a bug as an interface hack, let me tell you about something Called "Moria" that us real veterans played back in the eighties before most of these so-called new 'veterans' were even born. Back when stores worked properly, and charisma had a purpose because people actually had to haggle.

As a computer programmer, not fixing this bug is an affront to me.

comment:10 Changed 8 years ago by magnate

  • Milestone changed from 3.2.0 to 3.3.0

Punting to 3.3: non-urgent bug or change.

comment:11 Changed 8 years ago by magnate

  • Milestone changed from 3.3.0 to 3.2.0
  • Resolution set to wontfix
  • Status changed from reopened to closed

Closed by agreement with takkaria on IRC. We fixed it, people didn't like the fix, so we unfixed it. Long live democracy.

Note: See TracTickets for help on using tickets.