Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#974 closed change (fixed (in master))

Randarts: dragon scale mail

Reported by: smegdwarf@… Owned by: magnate
Milestone: 3.1.2 beta Keywords: items
Cc:

Description

A minor 'bug': I just found an artifact black dragon scale mail (very cool)... but it doesn't activate for breathe acid (or anything else for that matter).

3.1.1 on Windows.

Change History (5)

comment:1 Changed 10 years ago by Nightmarjoo

Yeah I had the same thing with a Green Dragon Scale Mail of Goron.

comment:2 Changed 10 years ago by anonymous

Heh, "of Goron"? So is it so unwieldy that only a Half-Troll can use it without massive DEX penalties, but it provides +150 AC and resistance to fire? ;)

comment:3 Changed 10 years ago by magnate

  • Keywords items added; dragon scale mail, randarts removed
  • Milestone changed from Triage to Future
  • Owner set to magnate
  • Status changed from new to assigned
  • Type changed from bug to change

This is not a bug - the current code cannot randomise artifact activations, so a randart will only have an activation if the artifact on which it is based has one. To make this work, all intrinsic DSM activations are removed when the randart is created. It does work as designed: if Orome is turned into a randart DSM, it will activate for Stone to Mud.

I'll leave this open as a feature request, as it's item d on my to-do list (#798).

comment:4 Changed 9 years ago by magnate

  • Resolution set to fixed
  • Status changed from assigned to closed

[957f5a4] (SVN r1699). Randart DSMs will now always have an activation: it may be the original breath weapon, or it may be some other activation. It's .... random.

comment:5 Changed 9 years ago by magnate

  • Milestone changed from Future to 3.1.2 beta
Note: See TracTickets for help on using tickets.