Opened 10 years ago

Closed 10 years ago

#978 closed bug (fixed (in master))

Squelched unknown flavours show up in object knowledge menu

Reported by: magnate Owned by:
Milestone: 3.1.2 beta Keywords: squelch
Cc:

Description

Steps to reproduce:

  1. Start a new game - check that all squelch options are zeroed. Specifically, check that the object knowledge menus show no flavours as squelched.
  1. Walk into store #5 to see a load of scrolls. You don't know the flavours of these scrolls, but you now know they exist.
  1. Go to the squelch menu, via options, and choose to squelch any or all of the scrolls you now know about.
  1. Go to the object knowledge menu, and see the unknown flavours now marked as squelched.

Change History (4)

comment:1 Changed 10 years ago by magnate

  • Status changed from new to confirmed

The difficulty with solving this is going to be distinguishing between items which are marked as squelched whose name is known but flavour is not, and vice versa. e.g. It's perfectly valid to choose to squelch purple potions, if I don't know what they are. It's also valid for me to squelch potions of sleep, even if I don't know what flavour they are. Somehow the game needs to avoid mixing those two cases up and giving away information which links flavours to items.

comment:2 Changed 10 years ago by magnate

In http://angband.oook.cz/forum/showthread.php?p=25414 Eddie points out that the problem is likely to be on the knowledge menu, rather than the squelching setup.

comment:3 Changed 10 years ago by magnate

[ec23f84] (SVN r1690)

comment:4 Changed 10 years ago by magnate

  • Resolution set to fixed
  • Status changed from confirmed to closed
Note: See TracTickets for help on using tickets.