Opened 9 years ago

Closed 9 years ago

#981 closed bug (invalid)

Problems with randart light source activations

Reported by: magnate Owned by: magnate
Milestone: 3.1.2 beta Keywords: items
Cc:

Description

In my last two games the Phial has had the wrong activation:

"When activated, it maps the entire level and detects objects, traps, doors, and stairs."

I think that's the activation of the Palantir (or maybe the Arkenstone, I forget which). I've done a total make clean and recompile, so this is not a compilation issue. No idea how it can have come about, because lights have been randomised fine since 2002.

Grateful if someone else could confirm this bug, so I can be sure it's not just me.

Looking at the artifact spoiler for the game where this occurred, all four light sources exist, but all have the wrong activations. Perhaps the problem is somewhere in the effects system.

Change History (3)

comment:1 Changed 9 years ago by takkaria

Have you deleted the raw files and regenerated them?

comment:2 Changed 9 years ago by magnate

Ah, thank you. I hadn't thought of that. Will try it and see.

comment:3 Changed 9 years ago by magnate

  • Resolution set to invalid
  • Status changed from new to closed

Note to self: whenever doing a make clean and recompile to try and get rid of this kind of problem, make sure to delete the raw files as well. Bring on the death of raw files!

Note: See TracTickets for help on using tickets.