Opened 10 years ago

Closed 10 years ago

#985 closed bug (worksforme)

Crash when running ends next to the dungeon wall

Reported by: Matthias Owned by:
Milestone: Triage Keywords:
Cc:

Description

Current nightly crashes when the running command is interrupted while just reaching the dungeon wall. It doesn't crash when running is interrupted while running next to the wall.

Attachments (1)

Jolinar (55.5 KB) - added by Matthias 10 years ago.
Savefile to reproduce the bug

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Matthias

Savefile to reproduce the bug

comment:1 Changed 10 years ago by magnate

I cannot reproduce this bug. For some reason the savefile doesn't load properly for me - just puts me into the birth process.

comment:2 Changed 10 years ago by MarbleDice

Savefile loaded for me, but I was unable to reproduce any crashing behavior by running in any direction from the starting position.

comment:3 Changed 10 years ago by Matthias

Yup same here, doesn't crash for [e75662a] (SVN r1760) anymore, I used version [59055ff] (SVN r1701) when reporting.

Btw: The idea was to run into the dead end at the right side that ends next to the outer wall, or running up using the left entrance of the small loop next to the outer wall

comment:4 Changed 10 years ago by magnate

  • Resolution set to worksforme
  • Status changed from new to closed

Closing until it can be reproduced.

Note: See TracTickets for help on using tickets.