Opened 10 years ago

Closed 10 years ago

#988 closed bug (fixed (in master))

Artifact spoilers do not include curses

Reported by: magnate Owned by:
Milestone: 3.1.2 beta Keywords: wizmode
Cc:

Description

I'm not quite sure how this got broken - the spoilers used to mention curses, but I can no longer see how. I think it's to do with the ID changes and flags. The make_fake_artifact function carefully copies the LIGHT_CURSE flag (but not the HEAVY_CURSE one), and then the object_flags function (called from object_info_out) gets all the flags *except* TR2_CURSE_MASK. Yet somehow neither light curses nor heavy curses are shown in the artifact spoiler.

I'm reluctant to change this until I understand why it was designed like this in the first place.

Change History (1)

comment:1 Changed 10 years ago by magnate

  • Resolution set to fixed
  • Status changed from new to closed

[68052df] (SVN r1713). It's done like that because light and heavy curses can be removed. Doh.

Note: See TracTickets for help on using tickets.