Opened 4 years ago

Closed 2 years ago

#993 closed change (fixed (in v4))

Fully implement HURT_FIRE and HURT_COLD

Reported by: MarbleDice Owned by: magnate
Milestone: 4.0 Keywords: combat monster
Cc:

Description

Monsters with HURT_FIRE and HURT_COLD take x2 damage from spell effects, but no monsters have these flags.

Additionally, monsters with these flags should probably take extra damage from weapon brands - perhaps x5 instead of x3.

See also #443.

Change History (8)

comment:1 Changed 4 years ago by magnate

And monsters with HURT_ROCK should take more damage from weapons with IMPACT or with TUNNEL pvals.

comment:2 Changed 4 years ago by KZK

HURT_LIGTNING or HURT_ELEC should also be implemented. I've always thought there should be more than three basic elementals, but at least all of the ones that currently exist should be implemented. Also, there should be a more granular aproach to sensitivity to elements.

comment:3 Changed 3 years ago by magnate

  • Milestone changed from 3.2.0 to 4.0

Not a bug or refactor: punting to 4.0

comment:4 Changed 3 years ago by magnate

  • Status changed from new to confirmed

comment:5 Changed 3 years ago by magnate

  • Type changed from bug to change

comment:6 Changed 3 years ago by magnate

  • Owner set to magnate
  • Status changed from confirmed to assigned

N.B. Need to make sure that where a monster's base kind has HURT_FOO and the monster itself has IM_FOO, we don't display both in monster recall. See http://angband.oook.cz/forum/showthread.php?t=4962 re death molds.

comment:7 Changed 3 years ago by magnate

Initial assignment to v4 per http://trac.rephial.org/roadmap

comment:8 Changed 2 years ago by magnate

  • Resolution set to fixed (in v4)
  • Status changed from assigned to closed

[r9ef0971]

Note: See TracTickets for help on using tickets.