Opened 8 years ago

Closed 8 years ago

#1523 closed bug (fixed (in master))

Keymaps (e.g. the rogue-like keys) can be disabled by Num Lock in trunk

Reported by: rriegs Owned by: david3x3x3
Milestone: 3.4.0 Keywords: keymaps keyset InputRework
Cc:

Description (last modified by magnate)

It took me forever to figure out what was going on, but it looks like Num Lock being active prefixes every key code with "{M}", the upshot being that keymaps (e.g. the rogue-like keys) don't work as intended under Num Lock. I don't know if this is specific to my computer or configuration, so here are the details:

VAIO VPCEB47GM
Ubuntu 10.10
angband -mx11 (trunk)

A practical fix is to duplicate the keymap definitions in pref.prf to include the "{M}" prefix as well. Or to just turn off Num Lock, though it's not *at all* clear that you should have to do so.

(As an aside, the second key mapping commented "Pickup an item (with autopickup)" should probably use the rogue-like keymap ID, e.g. "C:1:g" instead of "C:0:g".)

Change History (4)

comment:1 Changed 8 years ago by magnate

  • Keywords keymaps keyset InputRework added

I cannot reproduce this bug - has it been fixed?

comment:2 Changed 8 years ago by david3x3x3

  • Owner set to david3x3x3
  • Status changed from new to assigned

comment:3 Changed 8 years ago by david3x3x3

I've seen this issue. It may only be present with roguelike keys enabled and -mx11. If you have num-lock on and press hjkl, it looks like it's trying to run commands from the standard keymap instead of the roguelike keymap.

comment:4 Changed 8 years ago by magnate

  • Description modified (diff)
  • Milestone changed from Triage to 3.4.0
  • Resolution set to fixed (in master)
  • Status changed from assigned to closed

[763f079] in master and [68df01d] in v4-master.

Note: See TracTickets for help on using tickets.