Opened 8 years ago

Closed 8 years ago

#1584 closed bug (fixed (in master))

Use orange asterisks for unseen gold

Reported by: magnate Owned by: takkaria
Milestone: 3.4.0 Keywords: display
Cc:

Description (last modified by takkaria)

At the moment, red asterisks which are gold items appear in the object list summary, which gives away if there is only one:

http://angband.oook.cz/forum/showthread.php?p=63480#post63480

If we used an orange asterisk, they'd be indistinguishable from treasure veins until LOS, and need not appear on the object list at all.

Change History (7)

comment:1 Changed 8 years ago by magnate

  • Status changed from new to confirmed

This is actually really hard, because grid_data_as_text() knows only that there is an unseen object in that grid; it has no idea of the tval of that object. So you cannot easily distinguish between gold and non-gold unknown objects on the map. The clunky fix is to add g->unseen_gold as well as g->unseen_object, but that screams hack. Should g->unseen_object be a pointer to a linked list of objects?

(The object list bit is easier, once this is sorted.)

comment:2 Changed 8 years ago by takkaria

IMO, you shouldn't be able to distinguish gold from objects when you do detection, they should all appear the same (and veins should appear as orange still). This is how I implemented it originally and I didn't consider it to be a bug. The problem is that UI is not being consistent in its display of unseen objects. If you look at the original commits, I did some work towards making the object list display unaware gold the same as unaware non-gold, but it's obviously not quite working. (If I hadn't have done that, it wouldn't have appeared in the object list summary at all.)

I don't think unseen_object should be a pointer to a linked list. I think it should be an integer listing how many objects there are in the grid. Serves the same purpose, less complicated.

comment:3 Changed 8 years ago by magnate

That sounds fine for the detection stuff - so what is the desired behaviour of the object list? That it should show all gold, or no gold, or only unknown gold?

comment:4 Changed 8 years ago by takkaria

Only unknown gold, I think.

comment:5 Changed 8 years ago by takkaria

  • Description modified (diff)
  • Owner set to takkaria
  • Status changed from confirmed to assigned

comment:6 Changed 8 years ago by fizzix

I think both treasure in walls and money on floor should be gold asterisks.

Also there's a bug with money on floor showing up in the item list as "and N others."

comment:7 Changed 8 years ago by fizzix

  • Resolution set to fixed (in master)
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.