Opened 5 years ago

Closed 19 months ago

#1939 closed bug (invalid)

gcu interface gives a blank screen on OpenBSD.

Reported by: vext01 Owned by:
Milestone: Future Keywords: openBSD



I'm trying to update the OpenBSD port of angband to 4.0.0.

The graphical mode works fine, however -mgcu gives a blank screen. I have tried TERM={vt100, xterm-color, xterm} and I am using LC-CTYPE=en_US.UTF-8. I have even tried changing my terminal colour scheme to no avail.

I can escape the blank screen by hitting ctrl+c, so I think the game is running, just the graphics cannot be seen.

May be related to #1638?

Change History (4)

comment:1 Changed 5 years ago by nckmccnnll

  • Milestone changed from Triage to Future

Sticking in future with #1638

comment:2 Changed 4 years ago by vext01


See the remark about _OPEN_SOURCE_EXTENDED

comment:3 Changed 3 years ago by nckmccnnll

  • Keywords openBSD added

Marking all OpenBSD bugs as such and setting them to Future

comment:4 Changed 19 months ago by vext01

  • Resolution set to invalid
  • Status changed from new to closed

This is fixed in newer OpenBSDs. It was not the fault of angband.

Note: See TracTickets for help on using tickets.